Addressing active levelling errors

This error can appear after active leveling. Part of the active leveling procedure is checking the offset between the two print cores. Because of the switching mechanism, one print core will always be lower than the other. If this error appears, the measured Z offset of the two print cores is not as expected. This error can appear on the Ultimaker S5, Ultimaker S3, and Ultimaker 3.

Note: Active levelling errors can show up as: i) Difference between detected height of both PrintCores exceeds realistic values (code 30), ii) Nozzle offset probe failed (code 47)

There can be several causes for this error, but it is most likely that there was a problem during the active leveling procedure. To resolve this issue, follow the active leveling procedure again and carefully observe the printer's behavior. Pay attention to the following:

Make sure that your nozzles are clean

Material that is stuck to one or both of the nozzles can influence the readings. Although the nozzles are heated up before the procedure begins, if a blob of material is too big, it will not melt away completely and will add to the height of the print core.

Before restarting active leveling, clean the outside of the nozzles as described on this page.

Make sure that your glass plate is clean

When a nozzle is pressed against the glass during active leveling, this can leave behind some filament residue on the plate. This residue can cause inaccuracies in the readings if you go through the active leveling procedure again. Make sure there are no impurities on the surface of the glass plate.

Note: a thin layer of glue correctly applied to the glass plate will not affect the readings during active leveling.

Make sure that the bed is not set too high

For active leveling to work correctly, there should be at least 0.5 mm between the tip of the nozzle and the glass plate at the start of the procedure. If the nozzle is already touching the glass, the Ultimaker 3D printer cannot perform the measurements correctly.

After having followed the manual leveling procedure multiple times, the build plate springs can become too loose and the bed too high. Turn the three knurled nuts counter-clockwise to tighten the screws. Reset the bed back to the factory position:

  • For the Ultimaker 3 and S3, there should be a distance of approximately 14 mm between the bottom of the heated bed and the top of the aluminum base plate.
  • For the Ultimaker S5, the thumb wheels should be fully tightened. Then, loosen with 2 full turns clockwise.

Now manually level the build plate once more to ensure that it is leveled correctly before trying active leveling again.

Check the lift switch calibration

It is important that the print core switching functions well. If not, the active leveling procedure will detect the same height for both cores, which also 'exceeds realistic values' and could therefore cause this error message.

If the print head does not move to the switch bay correctly, perform a lift switch calibration to properly store the position. This only takes a few minutes. Our support pages have detailed instructions on how to perform this calibration for S-line printers and for the Ultimaker 3.

Switch-calibration.jpg

Check the capacitive sensor wires in the printhead

If the problem is persistent after the advice above has been followed, it is worth checking the active leveling hardware. The capacitive sensor board which enables active leveling is located in the front fan bracket of the print head. This is connected with a red (sensor) and white (shield) wire. Check if both of these wires are still properly connected. If they have come loose or show signs of damage, reach out to support for further advice.

See the following pictures for reference:

Capacitive-sensor-wires-ok.JPG Capacitive-sensor-wires-broken.jpg
OK: Both wires are securely connected to the board and no damage is visible Not OK: One of the wires is broken and disconnected from the board

 

Check the front fan cable

If the front fan cable has become damaged through wear and tear or improper placement, it could lead to electrostatic interference on the capacitive sensor board. This would result in incorrect readings during active leveling.

Disconnect the front fan cable to see whether this allows active leveling to occur. You can do this by disconnecting the connecter marked in orage in the following picture:

Print_Head_Connectors.jpg

Once disconnected, you can try to start a print job and see if the active levelling error occurs again. If not, we have localised the problem to interference caused by the front fan.

Warning: Do not run prints with the fan unplugged. Stop the printer after you determine whether or not active leveling has succeeded with it unplugged. Running the printer without the front fan will cause filament swelling and print failures. In severe cases, the swell may block print core removal. If this happens, you will need to disassemble the printhead.

Change the print cores

It could be that there is a faulty print core is affecting the active leveling reading. Check to see if the the following helps:

  • Change the print cores, place print core 1 to print core 2
  • Try using new print cores 

Still encountering issues?

If all the above changes have not worked, get in contact with support to troubleshoot further. To be able to service your issue quickly, please provide as much detail about your issue, along with log files and pictures of the print head, capacitive sensor board, and all wirings.

 

Was this article helpful?
6 out of 28 found this helpful

Comments

0 comments

Article is closed for comments.